Apache Tomcat CVE-2017-5648 Information Disclosure Vulnerability

Description:  While investigating bug 60718, it was noticed that some calls to application listeners in Apache Tomcat 9.0.0.M1 to 9.0.0.M17, 8.5.0 to 8.5.11, 8.0.0.RC1 to 8.0.41, and 7.0.0 to 7.0.75 did not use the appropriate facade object. When running an untrusted application under a SecurityManager, it was therefore possible for that untrusted application to retain a reference to the request or response object and thereby access and/or modify information associated with another web application.

Impact: Attackers can exploit this issue to obtain sensitive information that may aid in further attacks. Apache Tomcat 9.0.0.M1 through 9.0.0.M17, 8.5.0 through 8.5.11, 8.0.0.RC1 through 8.0.41, and 7.0.0 through 7.0.75 are vulnerable.

Mitigation: Updates are available. Please check specific vendor advisory for more information.

Reference URL’s: